EIGRP with VLANs

This how to is a continuation of the how to found here.  The Packet Tracer of this how to can be found here.

In this how to, the the EIGRP routing protocol is being deployed. In addition the VLANs will be able to communicate with two new networks introduced, 10.0.0.0/8 and 192.168.5.192/27. Overall most of the the networks used in these examples are not efficiently broken down with VSLM. The focus for now is to understand and learn routing and routing protocols.

In this example we will use EIGRP with the VLANs we already created which will be able to communicate with the two new networks as mentioned above.

EIGRP

 

Make sure Router 0 can handle the traffic from the VLANs. We managed to do that by running the following commands in the previous how to. You can verify the router is aware of the VLANs by pinging the VLAN router interfaces 192.168.50.100 and so forth. Below are the commands that we used to make Router 0 aware of the VLANS.

On Router 0 run the following only if you cannot ping from one of the workstations the network address for each VLAN:

For VLAN 50

 
interface fastEthernet 0/0.50
encapsulation dot1Q 50
ip address 192.168.50.100 255.255.255.0

For VLAN 60

 
interface fastEthernet 0/0.60
encapsulation dot1Q 60
ip address 192.168.60.100 255.255.255.0

For VLAN 99

 
interface fastEthernet 0/0.99
encapsulation dot1Q 99
ip address 192.168.99.100 255.255.255.0

For VLAN 150

 
interface fastEthernet 0/0.150
encapsulation dot1Q 150
ip address 192.168.150.100 255.255.255.0

 

Configure the FastEthernet and Serial connections of Router 0

The FastEthernet 0/0 is not assigned an IP address simply because it handles traffic from all VLANs.

For Interface FastEthernet 0/1 execute

interface FastEthernet 0/1
ip address 10.0.0.1 255.0.0.0
no shutdown

For Interface Serial 0/2/0 execute

interface Serial 0/2/0
ip address 192.168.5.225 255.255.255.252
no shutdown

For Interface Serial 0/2/1 execute

interface Serial 0/2/1
clock rate 64000
ip address 192.168.5.234 255.255.255.252
no shutdown

Setup EIGRP on Router 0

router eigrp 1
network 10.0.0.0  0.255.255.255
network 192.168.5.224  0.0.0.3
network 192.168.5.232  0.0.0.3

 

Configure the FastEthernet and Serial connections of Router 1

For Interface FastEthernet 0/0 execute

interface FastEthernet 0/0
ip address 192.168.5.1 255.255.255.128
no shutdown

For Interface Serial 0/2/0 execute

interface Serial 0/2/0
ip address 192.168.5.229 255.255.255.252
no shutdown

For Interface Serial 0/2/1 execute

ip address 192.168.5.226 255.255.255.252
clock rate 64000
no shutdown

Setup EIGRP on Router 1

router eigrp 1
network 192.168.5.0   0.0.0.127 
network 192.168.5.228 0.0.0.3   
network 192.168.5.224 0.0.0.3

 

Configure the FastEthernet and Serial connections of Router 2

For Interface FastEthernet 0/0 execute

interface FastEthernet 0/0
ip address 192.168.5.193 255.255.255.224
no shutdown

For Interface Serial 0/2/0 execute

interface Serial 0/2/0
ip address 192.168.5.233 255.255.255.252
no shutdown

For Interface Serial 0/2/1 execute

interface Serial 0/2/1
clock rate 64000
ip address 192.168.5.230 255.255.255.252
no shutdown

Setup EIGRP on Router 1

router eigrp 1
network 192.168.5.192  0.0.0.31 
network 192.168.5.232  0.0.0.3  
network 192.168.5.228  0.0.0.3 
Share Button

Static Routing

This is a continuation of the previous how to located here.  You can download this Packet Tracer file from here.

In this how to, we have configured router 0 to allow communication between networks 10.0.0.0 and 192.168.50.100

You do this by running the following command on Router 0

ip route 10.0.0.0 255.0.0.0  10.0.0.0

 

Static_routing

Share Button

PVST – Per VLAN Spanning Tree Protocol

This how to shows how to setup PVST (Per VLAN Spanning Tree Protocol) for the VLANs created. Keep in mind the model I created here is not robust enough to support full redundancy for all VLANs but it will do just fine to show how PVSTs can be setup. This particular Packet Tracer file can be downloaded from here

In few words, assuming we have VLANs 50,60,99 and 150, PVST determines which switch will be the Root Primary Switch for VLAN50 and which Switch will be the Root Secondary for VLAN50. The same goes for the rest of the VLANs.

We are using the setup from the previous posts.
VLAN-SWITCH-REDUNANCY

On Switch 3 run the following commands.

spanning-tree mode  pvst 
spanning-tree vlan 50 priority 0
spanning-tree vlan 60 priority 0
spanning-tree vlan 80 priority 0
spanning-tree vlan 99 priority 0
spanning-tree vlan 150 priority 0

On Switch 4 run the following commands.

spanning-tree mode  pvst 
spanning-tree vlan 50 root secondary
spanning-tree vlan 60 root secondary
spanning-tree vlan 80 root secondary
spanning-tree vlan 99 root secondary
spanning-tree vlan 150 root secondary

On Switch 2 we can run few commands to increase performance by enabling instant forwarding and by also enabling bpdu-guard. These commands should be run only on switches that hosts are connected.

#On the switch that the hosts are connected. It will enable fast forwarding.
spanning-tree portfast
#On the switch that the hosts are connected. It will enable bpguard
spanning-tree BPDUguard
Share Button

Create a Redundant Switch environment.

This how to is a further expansion of the previous how to located . In this how to switch redundancy is introduced for all VLANs. You can download the setup for this Packet Tracer from here

VLAN-SWITCH-REDUNANCY

 

 

 

 

Going by the image, there are three new switches introduced, SWITCH2, SWITCH3 and SWITCH4. Switches 3 and 4 connect to Switch2 which handles the traffic for those particular hosts. Also, Switches 3 and 4 connect to Switch 0, making possible the communication with the VLANS and the hosts being handled by Switch1.

The following commands will need to be run on SWITCH 2 – 3 – 4.

#Create and Name the VLANs
On Switch 2
vlan 50
name students
vlan 60
name teachers
vlan 99
name mgt
vlan 80
name native

#Change the Default VLAN from 1 to 80
interface fastEthernet 0/1
switchport truck native vlan 80

#Assign ports 5 to 15 on VLAN 50
interface range fastEthernet 0/5-15
switchport mode access
switchport access vlan 50

#Assign ports 21 to 23 to VLAN 60
interface range fastEthernet 0/21-23
switchport mode access
switchport access vlan 60

#Assign port 24 to VLAN 99
interface fastEthernet 0/24
switchport mode access
switchport access vlan 99

 

The following commands will need to be run on Switch 3

interface fastEthernet 0/1
switchport mode trunk
switchport trunk allowerd vlan 1-99,150

interface fastEthernet 0/2
switchport mode trunk
switchport trunk allowerd vlan 1-99,150

 

The following commands will need to be run on Switch 4

interface fastEthernet 0/1
switchport mode trunk
switchport trunk allowerd vlan 1-99,150

interface fastEthernet 0/2
switchport mode trunk
switchport trunk allowerd vlan 1-99,150
Share Button

Configure DHCP on Router and handle VoIP phones

This how to is a continuation of  the previous here . The VoIP configured PacketTracer file can be downloaded from here.

VLAN4

In this how to the router will be configured to also act as a DHCP server. Also the VLAN 150 will converted to be able to handle telephony. Also some minor changes will be done on the switch it self in order for it to handle telephony data. Next on some of the commands below are comments to explain what each command does.

Configure DHCP on the router.

 
configure  terminal 
name of your IP Pool
network 192.168.150.0 255.255.255.0
default-router  192.168.15.1
option 150 ip 192.168.150.1  #set raw DHCP options. the 150 is for telephony.
end

Configure the router to understand Telephony data

 
telephony-service
max-dn 10 #Maximum directory numbers
max-ephones 10 #Maximum phones to support
ip source-address 192.168.150.1 port 2000  #The network IP and the default port used.
auto assign 1 to 9 #Automatically assigns ext number to buttons
end

On the switch Re-configure VLAN-150 from Access port to Voice port and assign port 20 to a phone

 
interface FastEthernet 0/20
switchport mode access
no switchport access vlan 150
switchport voice vlan 150 

Configure the router to assign a dial number to the phone

 
ephone-dn 1 #Configure phone number 1, 2....n etc 
number 62001 #give this extension number to the phone
Share Button

Configure Router to handle traffic from VLANs.

This how to is a continuation of  the previous howto . You can download the PacketTracer file from here.

In this how to a router will be configured to handle traffic from all VLANs. The router will handle traffic from all networks created by the VLANs. Each host on each VLAN will be then be able to ping the router’s IP address. The router’s IP address for hosts on different VLANs will belong to the network the VLAN operates in. In other words a host in the VLAN 50 will have as default gateway 192.168.50.100 and so forth with the rest of the hosts on the different VLANs.

VLAN4

 

Create Trunk between Switch 1 and Router 1. Run the following commands on Switch 1

 
interface fastEthernet 0/2
switchport mode trunk
switchport trunk allowed vlan 1-99,150

Configure the router.

For VLAN 50

 
interface fastEthernet 0/0.50
encapsulation dot1Q 50
ip address 192.168.50.100 255.255.255.0

For VLAN 60

 
interface fastEthernet 0/0.60
encapsulation dot1Q 60
ip address 192.168.60.100 255.255.255.0

For VLAN 99

 
interface fastEthernet 0/0.99
encapsulation dot1Q 99
ip address 192.168.99.100 255.255.255.0

For VLAN 150

 
interface fastEthernet 0/0.150
encapsulation dot1Q 150
ip address 192.168.150.100 255.255.255.0
Share Button

Create VLANS – Trunking, Two Switch Configuration, Change native VLAN

In this how to, two switches are configured to communicate with VLANs. For not ignore the router. Each Switch is configured with the same VLANs, otherwise they will not know how to exist.. In addition, we are going to create a Trunk for both switches to communicate all VLANs between them. Download the PacketTracer file

VLAN4

Configure both switches to have the same VLANs. The process and VLAN creation will be exactly the same as with the  the commands found on the previous how to. However, on this switch we will add an additional VLAN for VoIP.  Below are the commands.

Create the VLANs, 50(students), 60(teachers), 99(mgt), 150(voice)

 
enable
configure terminal
vlan 50
name students
vlan 60
name teachers
vlan 99
name mgt
vlan 150
name voice

Assign ports to each VLAN
For VLAN students (ports 5 to 20 on interface 0)

interface range fastEthernet 0/5-15
switchport mode access
switchport access vlan 50

For VLAN teachers (ports 21 to 23 on interface 0)

interface range fastEthernet 0/21-23
switchport mode access
switchport access vlan 60

For VLAN mgt (ports 24 on interface 0) and also assign IP address in order to communicate with the switch

interface fastEthernet 0/24
switchport mode access
switchport access vlan 99
interface vlan 99
ip address 192.168.99.2 255.255.255.0
no shutdown

For VLAN voice (ports 24 on interface 0)

interface range fastEthernet 0/16-20
switchport mode access
switchport access vlan 150

Create the Trunk.

On a switch ports 1 to 4 belong to VLAN1, which is a factory default. We take port 1 on both switches in order to create the Trunk as mentioned above. Here are the commands to create the trunk; execute these on both switches.  Below the listed VLANs will be handled by the trank. We include the 150 VLAN as well in the last command.

interface fastEthernet 0/1
switchport mode trunk
switchport trunk allowerd vlan 1-99,150

Change native VLAN

The default setting for native VLAN is VLAN 1. However we can change this to be on a different VLAN. We can do this by simply issuing the following command. This will have to be executed on both connected switches.

vlan 80
name native
interface fastEthernet 0/1
switchport trunk native vlan 80
Share Button

Create VLANS – One Switch Configuration

A VLAN is a seperate LAN. It can be created on the switch. Each switch has a default VLAN which is VLAN1. Hosts can be on the same subnet or not. Best practices dictate they should be on different subnets. Below are the commands to create two VLANS. The Student VLAN and the Management VLAN.VLAN

Create the VLANs, 50(students), 60(teachers), 99(mgt), 150(voice)

 
enable
configure terminal
vlan 50
name students
vlan 60
name teachers
vlan 99
name mgt

Assign ports to each VLAN
For VLAN students (ports 5 to 20 on interface 0)

interface range fastEthernet 0/5-15
switchport mode access
switchport access vlan 50

For VLAN teachers (ports 21 to 23 on interface 0)

interface range fastEthernet 0/20-23
switchport mode access
switchport access vlan 60

For VLAN mgt (ports 24 on interface 0) and also assign IP address in order to communicate with the switch

interface fastEthernet 0/24
switchport mode access
switchport access vlan 99
interface vlan 99
ip address 192.168.99.2 255.255.255.0
no shutdown
Share Button